SAP NetWeaver contourne les problèmes de compatibilité Java

Cloud

Les développeurs pourront désormais exécuter du code Java sur les serveurs
d’applications NetWeaver

La plate-forme SAP NetWeaver est dorénavant entièrement compatible avec Java Enterprise Edition 5, une évolution qui permettra aux utilisateurs d’exécuter des applications Java sur NetWeaver Application Server.

Cette option de compatibilité offre essentiellement les mêmes fonctionnalités qu’un serveur d’applications certifié Java EE 5, à cette différence que le code Java est exécuté à l’aide d’un conteneur JVM (Java Virtual Machine) et non d’un moteur JVM. SAP offre une compatibilité Java depuis 2003.

Sun Microsystems a dévoilé la spécification Java EE 5 en début d’année. La plate-forme, auparavant connue sous le nom de J2EE, est destinée aux applications d’entreprise basées sur des serveurs.

NetWeaver n’ayant pas obtenu la certification Java, SAP ne sera pas en mesure de désigner son produit sous l’appellation de serveur d’applications Java.

Cette option de compatibilité permet à SAP de répondre à ses détracteurs d’Oracle qui reprochent à la plate-forme son manque de flexibilité.

Plus de 30 organisations possèdent une licence d’utilisation de la technologie Java EE leur permettant de développer leurs propres serveurs d’application. Oracle et BEA offrent actuellement des versions préliminaires de leurs serveurs d’applications Java EE 2.

Traduction d’un article de Vnunet.com en date du 2 octobre 2006.


Lire la biographie de l´auteur  Masquer la biographie de l´auteur